Задать вопрос
10 октября, 10:13

В двумерном массиве размерностью N*M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк

+5
Ответы (1)
  1. 10 октября, 10:27
    0
    uses crt;

    var i, j, min, n, m : integer; s:real;

    a:array[1 ... 100,1 ... 100] of integer;

    b:array[1 ... 100] of integer;

    begin

    readln (n, m) ;

    s:=0;

    for i:=1 to n do begin

    for j:=1 to m do

    a[i, j]:=random (25) + 1;

    end;

    for i:=1 to n do begin writeln;

    for j:=1 to m do

    write (a[i, j],' ') ;

    end; writeln;

    WriteLn ('Ìèíèìàëüíûå ýëåìåíòû ñòðîê:') ;

    for i:=1 to n do begin

    min:=a[i, j];

    for j:=2 to m do begin

    if min>a[i, j] then begin

    min:=a[i, j];

    end;

    end;

    s:=s+min;

    Write (min,' ') ;

    end;

    writeln ('avg = ', (s/n) : 0:1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В двумерном массиве размерностью N*M, содержащем целые числа, найти среднее арифметическое минимальных элементов строк ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль 1. В двумерном массиве вычислить A (4,4) найти наибольший элемент, лежащий на главной диагонали. 2. Дан массив A (5,5). Для данного натурального M найти сумму тех элементов массива, сумма индексов которых равна M (М - вводится с клавиатуры).
Ответы (1)
В двумерном массиве найти в двумерном массиве найти минимальные и максимальные элементы и вычислить их сумму произведение и разность (Составить программу)
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Информатика. Массивы. PascalABC. 1. В двумерном массиве 4 х5 вычислить сумму элементов кратных 3, значения которых больше 20. 2. Найти среднее арифметическое элементов главной диагонали квадратной матрицы 5 х5.
Ответы (1)
В двумерном массиве 10 х10, содержащем числа в интервале от 50 до 100 найдите сумму элементов стоящих на главной диагонале. Вывести на печать исходную матрице в табличном виде и значения матрицы и полученную сумму Pascal
Ответы (1)