Задать вопрос
22 января, 00:42

Написать программу Паскаль, которая решает следующую задачу: телефонные разговоры с тремя населенными пунктами стоят с1, с2, с3 коп./мин. Разговоры длились t1, t2, t3 минут сооветственно. Какова общая стоимость разговоров?

+3
Ответы (1)
  1. 22 января, 03:16
    0
    Program razgovor;

    uses crt;

    var c1, c2, c3:integer;

    t1, t2, t3:integer;

    begin

    Write ('Введите цену разговора с первым пунктом, с1 = ') ;

    Readln (c1) ;

    Write ('Введите цену разговора со вторым пунктом, с2 = ') ;

    Readln (c2) ;

    Write ('Введите цену разговора с третьим пунктом, с3 = ') ;

    Readln (c3) ;

    Write ('Введите длительность разговора с первым пунктом, t1 = ') ;

    Readln (t1) ;

    Write ('Введите длительность разговора со вторым пунктом, t2 = ') ;

    Readln (t2) ;

    Write ('Введите длительность разговора с третьим пунктом, t3 = ') ;

    Readln (t3) ;

    clrscr;

    Writeln ('Общая стоимость разговора = ', c1*t1+c2*t2+c3*t3)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу Паскаль, которая решает следующую задачу: телефонные разговоры с тремя населенными пунктами стоят с1, с2, с3 коп./мин. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Написать программу вычисления расстояния между населенными пунктами, изображенными на карте. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Ответы (1)
На схеме указаны дороги между четырьмя населенными пунктами и отмечены длины этих дорог. Длина одной дороги неизвестна. Зато известно, что самый короткий путь между двумя наиболее удаленными друг от друга населенными пунктами составляет 70 км.
Ответы (1)
1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)
Ответы (1)
Прошу помогите! Услуги телефонной сети оплачиваются по следующему правилу: за разговоры до А минут в месяц - В рублей за минуту, а разговоры сверх установленной нормы оплачиваются из расчета С рублей за минуту.
Ответы (1)