Задать вопрос
24 мая, 14:12

Прошу помогите!

Услуги телефонной сети оплачиваются по следующему правилу: за разговоры до А минут в месяц - В рублей за минуту, а разговоры сверх установленной нормы оплачиваются из расчета С рублей за минуту. Требуется написать программу, вычисляющую плату за пользование телефоном для введенного времени разговоров за месяц.

+4
Ответы (1)
  1. 24 мая, 17:54
    0
    Var a, d:integer; b, c, p:real;

    begin

    write ('A=') ; readln (a) ;

    write ('B=') ; readln (b) ;

    write ('C=') ; readln (c) ;

    write ('Разговоров за месяц: ') ; readln (d) ;

    if d<=a then p:=b*d else p:=b*a+c * (d-a) ;

    writeln ('Плата за телефон=', p:5:2) ;

    end.

    Пример:

    A=20

    B=1.70

    C=1.90

    Разговоров за месяц: 25

    Плата за телефон=43.50
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Прошу помогите! Услуги телефонной сети оплачиваются по следующему правилу: за разговоры до А минут в месяц - В рублей за минуту, а ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Телефонная компания взимает плату за услуги телефонной связи по следующему тарифу: 370 мин в месяц оплачиваются как абонентская плата, которая составляет 200 монет. За каждую минуту сверх нормы необходимо платить по 2 монеты.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Для адресации в сети с протоколом IPv4 используется следующий адрес ограниченного широковещания: 194.186.6.127, а служебный адрес IP-сети: 194.186.6.0. Какова маска данной сети.
Ответы (1)