Задать вопрос
23 мая, 19:39

Дана последовательность литер, имеющая следующий вид: d1± d2 ± ... ± dn (di цифры, n>1). Вычислить значение этой алгебраической суммы.

+4
Ответы (1)
  1. 23 мая, 20:22
    0
    const cf=['0' ... '9'];

    var s:string;

    i, sum, t, c:integer;

    begin

    writeln ('Vvedite posledovatelnost liter:') ;

    readln (s) ;

    val (s[1], t, c) ; sum:=t;

    for i:=2 to length (s) - 1 do

    begin

    if (s[ i ] in cf) and (s[i-1]='+') then

    begin

    val (s[ i ], t, c) ;

    sum:=sum+t;

    end

    else if (s[ i ] in cf) and (s[i-1]='-') then

    begin

    val (s[ i ], t, c) ;

    sum:=sum-t;

    end;

    end;

    writeln ('sum=', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность литер, имеющая следующий вид: d1± d2 ± ... ± dn (di цифры, n>1). Вычислить значение этой алгебраической суммы. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность чисел: 12323. К ней применён следующий цикл обработки: 1. Все цифры "1" заменить на "33" 2. Все цифры "2" заменить на "1" 3.
Ответы (1)
Дана последовательность чисел: 12323. К ней применен следующий цикл обработки: 1. Все цифры "1" заменить на "33" 2. Все цифры "2" заменить на "1" 3. Все цифры "3" заменить на "2"
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале
Ответы (1)
Как называется логическая операция, имеющая значение "истина", если истинно, хотя бы одно из составляющих высказывания и имеющая значение "ложь", если ложны все высказывания? А) дизъюнкция Б) композиция В) конъюнкция Г) отрицание
Ответы (1)