Задать вопрос
28 марта, 23:38

Дана последовательность чисел: 12323. К ней применен следующий цикл обработки:

1. Все цифры "1" заменить на "33"

2. Все цифры "2" заменить на "1"

3. Все цифры "3" заменить на "2"

+3
Ответы (1)
  1. 29 марта, 01:54
    0
    Вот решение на паскале.

    var b, k, i, l:integer; a:array[1 ... 100] of string; begin

    a[1]:='1';

    a[2]:='2';

    a[3]:='3';

    a[4]:='2';

    a[5]:='3';

    for i:=1 to 5 do

    begin

    if a[i]='1' then a[i]:='33';

    if a[i]='2' then a[i]:='1';

    if a[i]='3' then a[i]:='2';

    end;

    for i:=1 to 5 do

    write (a[i]) ;

    end.

    Ответ: 331212
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность чисел: 12323. К ней применен следующий цикл обработки: 1. Все цифры "1" заменить на "33" 2. Все цифры "2" заменить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность чисел: 12323. К ней применён следующий цикл обработки: 1. Все цифры "1" заменить на "33" 2. Все цифры "2" заменить на "1" 3.
Ответы (1)
В каком типе цикла тело цикла выполняется пока условие ложно? А) цикл со счетчиком Б) цикл с постусловием В) цикл с предусловием Г) цикл с рекурсией
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
3) Определите, сколько раз исполнится цикл:for i:=0 to 8 do write (i) ; A) Цикл будет бесконечным B) Вообще не исполнится C) 8 раз D) 9 раз 4) Определите, сколько раз исполнится цикл:for i:=-10 downto 0 do write (i) ;
Ответы (1)
При обработке массива из нулей и единиц 10100110 был применен следующий алгоритм: если первый элемент массива единица, то переносим её на третью с конца позицию, а если первый элемент массива нуль, то меняем местами первые два элемента массива.
Ответы (1)