Задать вопрос
13 декабря, 09:35

Дана последовательность чисел: 12323. К ней применён следующий цикл обработки:

1. Все цифры "1" заменить на "33"

2. Все цифры "2" заменить на "1"

3. Все цифры "3" заменить на "2"

например, после однократного выполнения этого цикла обработки получится последовательность S=221212

Запишите количество цифр в получившейся последовательности, если цикл применялся 14 раз.

+4
Ответы (1)
  1. 13 декабря, 12:41
    0
    Var i, j: integer;

    chislo: string;

    begin

    chislo:='12323';

    for j:=1 to 14 do

    begin

    i:=1;

    while i<=length (chislo) do

    begin

    if copy (chislo, i, 1) = '1' then begin delete (chislo, i, 1) ; insert ('33', chislo, i) ; inc (i) ; end;

    inc (i) ;

    end;

    i:=1;

    while i<=length (chislo) do

    begin

    if copy (chislo, i, 1) = '2' then begin delete (chislo, i, 1) ; insert ('1', chislo, i) ; end;

    inc (i) ;

    end;

    i:=1;

    while i<=length (chislo) do

    begin

    if copy (chislo, i, 1) = '3' then begin delete (chislo, i, 1) ; insert ('2', chislo, i) ; end;

    inc (i) ;

    end;

    end;

    Writeln (chislo) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность чисел: 12323. К ней применён следующий цикл обработки: 1. Все цифры "1" заменить на "33" 2. Все цифры "2" заменить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана последовательность чисел: 12323. К ней применен следующий цикл обработки: 1. Все цифры "1" заменить на "33" 2. Все цифры "2" заменить на "1" 3. Все цифры "3" заменить на "2"
Ответы (1)
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Проанализируйте работу программы. program math; var x, y: integer; begin x:=1; y:=1; while x
Ответы (1)