Задать вопрос
5 января, 02:27

Пользователь вводит трёхзначные числа с клавиатуры. Нужно вывести числа в записи которых все 3 цифры чётные. На языке Pascal. Помогите с написанием программного кода

+5
Ответы (1)
  1. 5 января, 04:36
    0
    Uses crt; var a:array[1 ... 100] of integer;

    b, k, l, i, n:integer;

    begin

    writeln ('Skolko chesel vy bydete vvodit?') ;

    read (n) ;

    for i:=1 to n do begin

    write ('Vvedite ', i,' chislo: ') ;

    read (a[i]) ;

    end;

    for i:=1 to n do begin

    b:=a[i] div 100;

    k:=a[i] div 10 mod 10;

    l:=a[i] mod 10;

    if (b mod 2 = 0) and (k mod 2 = 0) and (l mod 2 = 0) then writeln (a[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пользователь вводит трёхзначные числа с клавиатуры. Нужно вывести числа в записи которых все 3 цифры чётные. На языке Pascal. Помогите с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)
С + + Помогите! Вася работает программистом и получает 50$ за каждые 100 строк кода. За каждое третье опоздание Васю штрафуют на 20$.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Помогите с программой. Пользователь вводит с клавиатуры сумму, которая у него есть. Далее"садится за рулетку". Программа спрашивает, какая ставка и на что ставит. пользователь. Ставка идет на конкретное число (от 1 до 36).
Ответы (1)