Задать вопрос
24 августа, 16:26

Найти двузначные числа, обладающие тем свойством, что куб суммы его цифр равен квадрату самого числа.

+5
Ответы (1)
  1. 24 августа, 19:59
    0
    var i: integer;

    n1, n2: integer;

    begin

    for i : = 10 to 99 do

    begin

    n1 : = i div 10;

    n2 : = i mod 10;

    if (n1 + n2) * (n1 + n2) * (n1 + n2) = i * i then

    begin

    writeln (i) ;

    end

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти двузначные числа, обладающие тем свойством, что куб суммы его цифр равен квадрату самого числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найдите двузначное число, обладающее тем свойством, что куб суммы его цифр равен квадрату самого числа. (pascal)
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Найдите все двухзначные числа, обладающие свойством: если к сумме цифр числа прибавить квадрат этой суммы то получится само число.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Составить программу в Pascal: Найти все трехзначные числа, обладающие следующими свойствами: - сумма цифр числа А делится на 4; - сумма цифр числа А+2 также делится на 4
Ответы (1)