Задать вопрос
19 февраля, 06:26

Найдите двузначное число, обладающее тем свойством, что куб суммы его цифр равен квадрату самого числа. (pascal)

+4
Ответы (1)
  1. 19 февраля, 08:01
    0
    uses crt;

    var i, s, a, b:integer;

    begin

    for i:=10 to 99 do

    begin

    a:=i div 10;

    b:=i mod 10;

    s:=a+b;

    if s*s*s = sqr (i) then writeln (i) ;

    end;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите двузначное число, обладающее тем свойством, что куб суммы его цифр равен квадрату самого числа. (pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти двузначные числа, обладающие тем свойством, что куб суммы его цифр равен квадрату самого числа.
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)