Задать вопрос
5 июня, 22:36

Составить программу в Pascal:

Найти все трехзначные числа, обладающие следующими свойствами:

- сумма цифр числа А делится на 4;

- сумма цифр числа А+2 также делится на 4

+4
Ответы (1)
  1. 5 июня, 23:55
    0
    var i1, i2, s1, s2:integer;

    begin

    for i1:=100 to 997 do

    begin

    s1: = (i1 div 100) + (i1 div 10 mod 10) + (i1 mod 10) ;

    i2:=i1+2;

    s2: = (i2 div 100) + (i2 div 10 mod 10) + (i2 mod 10) ;

    if (s1 mod 4=0) and (s2 mod 4=0) then writeln (i1,' ', i2) ;

    end;

    end.

    Результат:

    299 301

    398 400

    699 701

    798 800
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в Pascal: Найти все трехзначные числа, обладающие следующими свойствами: - сумма цифр числа А делится на 4; - сумма ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
1) вывести трехзначные числа сумма цифр которых простое число pascal. 2) Дана последовательность 5,9,13,17, ... Составте программу для определения числа слагаемых, сумма которых равна 324.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)