Задать вопрос
28 мая, 03:19

Дано натуральное число n. Найти величину, обратную среднему арифметическому цифр заданного числа.

программа в Паскале.

+1
Ответы (1)
  1. 28 мая, 05:03
    0
    Var n, S, k:integer;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    S:=0;

    k:=0;

    While n > 0 do

    Begin

    S:=S+n mod 10;

    k:=k+1;

    n:=n div 10

    End;

    WriteLn (k/S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число n. Найти величину, обратную среднему арифметическому цифр заданного числа. программа в Паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
В паскале. Дано натуральное число n. Вычислить отношение суммы цифр к корню квадратному из суммы цифр заданного числа.
Ответы (1)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)