Задать вопрос
15 мая, 09:57

Составить программу вычисления суммы 1/2+1/4+1/6 + ... + 1/20 с использованием оператора repeat

ABCpascal

+3
Ответы (1)
  1. 15 мая, 13:44
    0
    Program p13;

    Var

    A:integer;

    S:real;

    Begin

    S:=0;

    A:=2;

    Repeat

    S:=S+1/A;

    A:=A+2;

    Until A>20;

    WriteLn ('S = ', S) ;

    End.

    Результат работы программы:

    S = 1.46448412698413
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу вычисления суммы 1/2+1/4+1/6 + ... + 1/20 с использованием оператора repeat ABCpascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу вычисления суммы натуральных чисел от 20 до 99 с использованием оператора repeat
Ответы (1)
1) Вывести Чётные числа с 18 до 62 с использованием оператора цикла "for" 2) Вывести нечётные числа в обратном порядке с 31 до 1 с использованием оператора цикла "for".
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
Аписать на Паскале программу с использованием оператора Repeat ... until, которая запрашивает с клавиатуры набор произвольных целых положительных чисел и ищет их сумму. Признаком окончания последовательности чисел является "0".
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)