Задать вопрос
20 мая, 18:05

Члены математического кружка ознакомились с понятием факториал числа - добуток натуральных чисел от 1 до данного числа: n! = 1 * 2 * 3 ... n. сделайте программу по которой можно будет сравнить значение факториала числа и его квадрата

+2
Ответы (1)
  1. 20 мая, 20:49
    0
    Var

    N, i:integer;

    F, K:real;

    Begin

    F:=1;

    Write ('N = ') ; Read (N) ;

    K:=N*N;

    For i: = 2 to N do

    F:=F*i;

    if F = K then WriteLn ('Факториал и квадрат равна: ', F,'=', K) ;

    if F < K then WriteLn ('Квадрат больше факториала: ', F,'<', K) ;

    if F > K then WriteLn ('Факториал больше квадрата: ', F,'>', K) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Члены математического кружка ознакомились с понятием факториал числа - добуток натуральных чисел от 1 до данного числа: n! = 1 * 2 * 3 ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С помощью repeat S = (x / (факториал) 1) + (х^2 / (факториал) 2) + (х^3 / (факториал) 3) + ... + (х^n / (факториал) n) + 0,0001
Ответы (1)
Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.
Ответы (2)
Построить блок-схему и написать программу 1. Вычислить S=1+2+3+4+ ...+N 2. Для данного N составить алгоритм вычисления факториала N!=1*2*3* ...*N
Ответы (1)
Как обозначается факториал на компьютере? К примеру, корень из х записывается как sqrt (x), квадрат числа пишется как x^2. А как подобным образом записать факториал?
Ответы (1)
Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)
Ответы (1)