Задать вопрос
30 июля, 20:55

Реализуйте рекурсивную функцию вычисления факториала натурального числа.

Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.

Формат входных данных

На вход ваша программа получает одно число - n (1≤n≤8) (1≤n≤8).

Формат выходных данных

Выведите одно число - факториал числа n.

+3
Ответы (2)
  1. 30 июля, 22:39
    0
    Var n:integer;

    function fact (n:integer) : longint;

    begin

    if n=1

    then fact:=1

    else fact:=n*fact (n-1) ;

    end;

    begin

    write ('n = ') ;

    readln (n) ;

    writeln (n,'! = ', fact (n)) ;

    end.

    Пример:

    n = 6

    6! = 720
  2. 31 июля, 00:23
    0
    Var n: int64;

    function f (n: int64) : int64;

    begin

    if (n = 1) then f : = 1

    else f : = f (n - 1) * n;

    end;

    begin

    readln (n) ;

    write (f (n)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите рекурсивную функцию вычисления суммы цифр натурального числа. Формат входных данных На вход ваша программа получает одно натуральное число n (n
Ответы (1)
Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1). Формат выходных данных Выведите одно число - количество цифр в числе n.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
С некоторого момента прошло N дней. Сколько полных недель прошло за этот период. Формат входных данных На вход программе подается 0≤N≤106. Формат выходных данных Вывести целое число - ответ на вопрос. Примеры: Вход 100 Выход 14
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)