Задать вопрос
22 октября, 22:24

Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у пользователя целое число n, вычислит значение факториала числа. (Линейное программирование, цикл с параметром)

+4
Ответы (1)
  1. 22 октября, 23:47
    0
    Var

    i, n, p:longint;

    begin

    Write ('Введите целое число n - > ') ; Readln (n) ;

    p:=1;

    for i:=2 to n do p:=p*i;

    Writeln ('n!=', p)

    end.

    Тестовое решение:

    Введите целое число n - > 5

    n!=120
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Факториалом числа 5 (обозначается 5!) называется значение следующего выражения: f=1*2*3*4*5. Составьте программу, которая запросив у ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Реализуйте рекурсивную функцию вычисления факториала натурального числа. Напоминаем, что факториалом числа называется произведение всех натуральных чисел, меньших или равных ему. К примеру, факториал 55 равен 5⋅4⋅3⋅2⋅15⋅4⋅3⋅2⋅1.
Ответы (2)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)