Задать вопрос
19 января, 11:24

Составить программу для решения задачи:

"Ввести число, обозначающее размер одной фотографии в Мбайтах. Определить, сколько фотографий поместится на флэш-карту объёмом 2 Гбайта."

Язык программирования: Pascal

+1
Ответы (1)
  1. 19 января, 15:21
    0
    1. С вещественными числами

    var

    k:real;

    begin

    Write ('Размер фотографии, мб: ') ; Read (k) ;

    Writeln ('На flash-card объемом 2 Гб поместится фото: ',

    Trunc (2*1024/k))

    end.

    Пример

    Размер фотографии, мб: 3.27

    На flash-card объемом 2 Гб поместится фото: 626

    2. С целыми числами

    var

    k:integer;

    begin

    Write ('Размер фотографии, мб: ') ; Read (k) ;

    Writeln ('На flash-card объемом 2 Гб поместится фото: ',2*1024 div k)

    end.

    Пример

    Размер фотографии, мб: 3

    На flash-card объемом 2 Гб поместится фото: 682
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу для решения задачи: "Ввести число, обозначающее размер одной фотографии в Мбайтах. Определить, сколько фотографий ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. (Язык программирования - Pascal). Составить фрагмент программы открытия и чтения строк из текстового файла. 2. (Язык программирования - C++).
Ответы (1)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)