Задать вопрос
19 января, 13:02

В четырехзначном числе определить сначала самую большую цифру и вывести ее, затем - самую маленькую цифру и вывести ее, затем найти разность большей и меньшей цифры.

+4
Ответы (1)
  1. 19 января, 14:57
    -1
    Const

    n=4; { количество разрядов (цифр) в числе }

    var

    a:array[1 ... n] of integer;

    i, j, k:integer;

    begin

    Write ('Введите ', n,'-значное число: ') ; Read (k) ;

    for i:=1 to 4 do

    begin a[i]:=k mod 10; k:=k div 10 end;

    for i:=1 to n-1 do

    for j:=i+1 to n do

    if a[i]>a[j] then begin k:=a[i]; a[i]:=a[j]; a[j]:=k end;

    Writeln ('Наибольшая цифра ', a[n],', наименьшая цифра ', a[1],

    ', их разность ', a[n]-a[1])

    end.

    Тестовое решение:

    Введите 4-значное число: 1421

    Наибольшая цифра 4, наименьшая цифра 1, их разность 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В четырехзначном числе определить сначала самую большую цифру и вывести ее, затем - самую маленькую цифру и вывести ее, затем найти ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Переставить в исходном четырёхзначном числе первые две цифры и последние две цифры местами. Например: Входное 1234, выходное 3412. (что тут делать) ?
Ответы (2)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Pascal. Тема: Циклы С клавиатуры вводится целое произвольное число 1) Вывести на экран первую и последнюю цифру числа. 2) Вывести на экран наибольшую цифру числа 3) Вывести на экран нечетные цифры этого числа
Ответы (2)
Составить программу, которая позволяет найти сумму первой и третьей цифры в четырехзначном числе.
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)