Задать вопрос
16 марта, 14:57

Переставить в исходном четырёхзначном числе первые две цифры и последние две цифры местами. Например: Входное 1234, выходное 3412. (что тут делать) ?

+3
Ответы (2)
  1. 16 марта, 16:34
    0
    var

    s: string;

    begin

    read (s) ;

    if length (s) > = 4 then

    writeln (s[3] + s[4] + s[1] + s[2]) ;

    end.
  2. 16 марта, 16:47
    0
    uses crt;

    var n, k, a, b:string;

    begin

    write ('Введите четырёхзначное число: ') ;

    readln (a) ;

    n:=copy (a, 1,2) ;

    k:=copy (a, 3,2) ;

    b:=k+n;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Переставить в исходном четырёхзначном числе первые две цифры и последние две цифры местами. Например: Входное 1234, выходное 3412. (что тут ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программы для решения задач Задача 1. Найти катет прямоугольного треугольника, если известна гипотенуза и прилежащий к искомому катету угол. Величину вводить в градусах. Ответ дать с точностью до 2-х знаков после запятой Задача 2.
Ответы (1)
Составьте программы для решения задач Задача 1. Найти площадь треугольника по двум сторонам и углу между ними. Величину Угла вводить в градусах. Ответ дать с точностью до трёх знаков после запятой Задача 2.
Ответы (1)
Расположите выражения сверху вниз в порядке возрастания их значений 1. 931 div 100 2. (1234 div 10) mod 10 3. 931 mod 100 4. (1234 mod 100) mod 10 5. (1234 div 100) mod 10 6. 931 mod 10 7.100 mod 10 8. 100 div 10
Ответы (1)
Алина задумала число из цифр 1,2,3,4. У задуманного числа и у чисел 1234, 2341, и 3412 одинак цифр в совпадающих разрядов нет. Какое число задумала Алина?
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)