Задать вопрос
11 марта, 03:52

Паскаль ABC.

Составьте программу, которая запрашивает ввод трех формул кислот и проверяет, есть ли среди них формула серной кислоты.

Использовать можно только if ... tnen ... else

+3
Ответы (1)
  1. 11 марта, 07:21
    0
    Var

    H2SO4:string;

    B:integer;

    Begin

    B:=0;

    WriteLn ('Введите три формулы кислот') ;

    ReadLn (H2SO4) ;

    if H2SO4 = 'H2SO4' then B:=1;

    ReadLn (H2SO4) ;

    if H2SO4 = 'H2SO4' then B:=2;

    ReadLn (H2SO4) ;

    if H2SO4 = 'H2SO4' then B:=3;

    if B = 0 then WriteLn ('Формулы серной кислоты среди них нет')

    else WriteLn ('Формула серной кислоты: №', B)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль ABC. Составьте программу, которая запрашивает ввод трех формул кислот и проверяет, есть ли среди них формула серной кислоты. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике