Задать вопрос
15 мая, 12:35

Паскаль!

Дана строка символов, состоящая из слов. Заменить в словах слог "ба" на "ро" (например, "база" - "роза"). Если таких слов нет, то выдать соответствующее текстовое сообщение.

+3
Ответы (1)
  1. 15 мая, 15:38
    0
    Var s: string;

    n, k: integer;

    begin

    n:=1; k:=0;

    write ('строка: ') ; readln (s) ;

    while n>0 do

    begin

    n:=pos ('ба', s) ;

    if (n>0) then

    begin

    k:=k+1;

    s[n]:='р';

    s[n+1]:='о';

    end;

    end;

    if k>0 then writeln ('новая строка: ', s)

    else writeln ('нет слога "ба" ') ;

    end.

    строка: большой баобаб

    новая строка: большой роороб
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! Дана строка символов, состоящая из слов. Заменить в словах слог "ба" на "ро" (например, "база" - "роза"). Если таких слов нет, то ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Написать программу на Python: 1. Использовать для решения задачи count. Дана строка, состоящая из слов, которые разделенны пробелами. Определить, сколько в ней слов. 2. Дана строка. Заменить в этой строке все буквы h на букву H.
Ответы (2)
Дана строка текста, состоящая из слов. Слова отделяются друг от друга одним из специальных символов, которые описываются во множестве ['-', '*', '/', ',']. Подсчитайте количество разделителей в строке. в паскале. строка дана любая
Ответы (1)