Задать вопрос
21 сентября, 10:10

Вводятся целые числа A и B. Выведите среднее арифметическое всех неотрицательных чисел от A до B

Нужно составить программу в паскале.

+5
Ответы (1)
  1. 21 сентября, 12:08
    0
    1 способ

    var

    a, b: integer;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    write ('Введите b: ') ;

    readln (b) ;

    var x : = Range (a, b) ;

    writeln ('Последовательность: ') ;

    x. Println;

    writeln ('Ср. ариф. неотриц чисел: ') ;

    writeln (x. Where (x - > x > = 0). Average) ;

    end.

    2 способ

    var a, b, i, s: integer; k: real;

    begin

    write ('Введите a: ') ;

    readln (a) ;

    write ('Введите b: ') ;

    readln (b) ;

    writeln ('Последовательность: ') ;

    for i:=a to b do write (i,' ') ;

    writeln () ;

    s:=0;

    for i:=a to b do

    if i>=0 then begin

    s:=s+i;

    k:=k+1;

    end;

    writeln ('Ср. ариф. неотриц чисел: ') ;

    write (s/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вводятся целые числа A и B. Выведите среднее арифметическое всех неотрицательных чисел от A до B Нужно составить программу в паскале. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
Составить программу в паскале с клавиатуы вводятся 5 чисел. после ввода каждого числа выводим среднее арифметическое введенной части P. S. пять чисел нужно выразить через одну переменную
Ответы (1)
Для пяти произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если первое, второе и пятое числа отрицательны, то выведите их произведение.
Ответы (1)