Задать вопрос
2 июня, 14:30

Составить программу в паскале

с клавиатуы вводятся 5 чисел. после ввода каждого числа выводим среднее арифметическое введенной части

P. S. пять чисел нужно выразить через одну переменную

+2
Ответы (1)
  1. 2 июня, 16:16
    0
    Var pr, sum, n:real; i:integer;

    Begin

    write ('Вводите числа: ') ;

    for i:=1 to 5 do begin

    readln (n) ;

    sum:=sum+n;

    end;

    pr:=sum/5;

    writeln ('среднее арифметическое равно: ', pr) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу в паскале с клавиатуы вводятся 5 чисел. после ввода каждого числа выводим среднее арифметическое введенной части P. S. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Разобрать прошрамму, которая вводит с клавиатуры последовательность из M дробных чисел и после ввода каждого числа выводит сумму и среднее арифметическое введенной части последовательности
Ответы (1)
Program u4_1; Var x, y : integer; Описываем используемые переменные Begin writeln ('Введите 2 числа ') ; На экран выводим поясняющую надпись "Введите 2 числа" readln (x, y) ;
Ответы (1)
Напишите программу, которая находит сумму, произведение и среднее арифметическое трёх целых чисел, введённых с клавиатуры. Входные данные Три целых числа вводятся в одной строке через пробелы.
Ответы (2)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
С клавиатуры вводятся целые числа. Окончание ввода - число ноль. Ноль используется только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру "5".
Ответы (1)