Задать вопрос
22 октября, 05:13

Точка с координатами (x, y) расположена на окружности с центром в начале координат, превосходит ли длина окружности заданную величину А. информатика помогите кто может.

+4
Ответы (1)
  1. 22 октября, 08:31
    0
    Var x, y, a, r, len: real;

    begin

    writeln ('Введите координаты точки') ;

    read (x, y) ;

    writeln ('Введите величину A') ;

    read (a) ;

    r : = sqrt (x * x + y * y) ;

    len : = 2 * PI * r;

    writeln ('Длина окружности: ', len:0:4) ;

    if (len > a) then

    writeln ('Длина окружности превосходит A')

    else

    writeln ('Длина окружности не превосходит A') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Точка с координатами (x, y) расположена на окружности с центром в начале координат, превосходит ли длина окружности заданную величину А. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 3. Написать программу, определяющую, лежит ли точка с указанными координатами А (x, y) на окружности радиуса R с центром в начале координат (может лежать на окружности, внутри окружности, вне окружности) PS: Pascal (не турбо) Всем буду
Ответы (1)
Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Составить программу на языке паскаль: Две точки задаются своими координатами. Определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.
Ответы (1)
расписать в паскале: На плоскости расположена окружность R в центре с началом координат. Определить положение точки X с координатами (A, B) относительно окружности (лежит ли точка внутри окружности на окружности или вне ее) Если можно полностью
Ответы (1)