Задать вопрос
22 августа, 01:45

Дано целое число, найдите в нем повторяющиеся цифры; выведите эти цифры и их количество (на Паскале)

+1
Ответы (1)
  1. 22 августа, 03:19
    0
    Program n1;

    var

    st: string;

    i, c: longint;

    b: boolean;

    procedure numdig (st: string; x: char) ;

    var i, k: longint;

    t: string;

    begin

    t:='';

    k : = 0;

    for i : = 1 to length (st) do

    begin

    if st[i] = x then k : = k + 1;

    end;

    if (k0) and (k1) then

    begin

    if (k=2) or (k=3) or (k=4) then t:='а';

    writeln ('цифра ', x,' повторяется ', k,' раз', t) ;

    c:=c+1;

    end

    end;

    begin

    c:=0;

    write ('введите число: ') ;

    read (i) ;

    str (i, st) ;

    numdig (st,'0') ;

    numdig (st,'1') ;

    numdig (st,'2') ;

    numdig (st,'3') ;

    numdig (st,'4') ;

    numdig (st,'5') ;

    numdig (st,'6') ;

    numdig (st,'7') ;

    numdig (st,'8') ;

    numdig (st,'9') ;

    if c=0 then writeln ('цифры не повторяются') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число, найдите в нем повторяющиеся цифры; выведите эти цифры и их количество (на Паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Решить в Паскаль АБЦ! Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число. "Входные данные" Вводятся два числа. "Выходные данные" Выведите ответ на задачу.
Ответы (1)
Первое задание дано целое двузначное число x. выведите число, полученное при перестановке его цифр. значение x ввести с клавиатуры второе задание дано целое трёхзначное число x.
Ответы (1)
Составьте блок-схемы и программы для решения следующих задач. Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. · Если разность первого и последнего, превышает второе, то выведите второе число.
Ответы (1)
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)