Задать вопрос
12 июля, 17:48

Составьте программу. Для вводимых с клавиатуры чисел определить количество четных и сумму нечетных чисел. Ввод прекращается когда пользователь вводит цифру 0

+2
Ответы (1)
  1. 12 июля, 21:26
    0
    Var A, c:longint;

    S:real;

    Begin

    c:=-1;

    S:=0;

    Repeat

    Read (A) ;

    if A mod 2 = 0 then c:=c+1

    else S:=S+A;

    Until A = 0;

    WriteLn ('Количество чётных: ', c) ;

    WriteLn ('Сумма нечётных: ', S) ;

    End.

    Пример работы программы:

    1 2 3 4 5 6 7 8 9 10 0

    Количество чётных: 5

    Сумма нечётных: 25
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу. Для вводимых с клавиатуры чисел определить количество четных и сумму нечетных чисел. Ввод прекращается когда ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы