Задать вопрос
7 ноября, 12:42

Напишите программу для Pascal

1) Пользователь вводит число, количество цифр в нем неизвестно, но последняя цифра = 0. Посчитать количество четных положительных цифр в этом числе.

2) Пользователь вводит число, посчитать количество цифр в числе и вывести минимальную цифру.

+5
Ответы (1)
  1. 7 ноября, 12:57
    0
    Program Ex1;

    var

    s: string;

    c: char;

    i, n, m, min: integer;

    begin

    s : = '';

    m : = 0;

    n : = 0;

    min : = 10;

    writeln ('Введите число') ;

    repeat

    read (c) ;

    s : = s + c;

    i : = StrToInt (c) ;

    if i mod 2 = 0 then

    if c '0' then m : = m + 1;

    / / для задания 2)

    n : = n + 1;

    if i < min then min : = i

    until c = '0';

    writeln ('Введено число ', s, ', в нем четных цифр - ', m)

    end.

    program Ex2;

    var

    s: string;

    i, d, n, min: integer;

    begin

    min : = 10;

    writeln ('Введите число') ;

    readln (s) ;

    n : = length (s) ;

    for i : = 1 to length (s) do

    begin

    d : = StrToInt (s[i]) ;

    if d < min then min : = d

    end;

    writeln ('Введено число ', s, ', в нем цифр - ', n, ', минимальная - ', min)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу для Pascal 1) Пользователь вводит число, количество цифр в нем неизвестно, но последняя цифра = 0. Посчитать количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Программирование. Pascal. Задача с циклом. Задача 1. Пользователь вводит 10 целых чисел. Посчитать, сколько из них положительных, отрицательных и нулей. Задача 2. Вводятся целые числа, ввод заканчивается 0.
Ответы (1)
Напишите полностью программу в Turbo Pascal. Создать программу в Turbo Pascal ... Пользователь вводит n элементов массива. Требуется определить количество элементов, значение которых больше, чем у предыдущего элемента массива
Ответы (1)
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)
1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc 2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC
Ответы (1)