Задать вопрос
19 октября, 08:45

Программирование. Pascal. Задача с циклом. Задача 1. Пользователь вводит 10 целых чисел. Посчитать, сколько из них положительных, отрицательных и нулей. Задача 2. Вводятся целые числа, ввод заканчивается 0. Посчитать, количество и произведение тех из них, которые > 0 и 100. Вывести, сколько чисел введено.

+2
Ответы (1)
  1. 19 октября, 12:41
    0
    Держи 1 и 3;) :

    1)

    Program solution;

    Uses Crt;

    Var i, poloz, otrits, zero : Byte;

    n : integer;

    Begin

    ClrScr;

    poloz : = 0;

    otrits : = 0;

    zero : = 0;

    for i : = 1 to 10 do

    begin

    readln (n) ;

    if n > 0 then poloz : = poloz + 1;

    if n < 0 then otrits : = otrits + 1;

    if n = 0 then zero : = zero + 1;

    end;

    write ('+: ', poloz, ', - : ', otrits, ', 0: ', zero) ;

    ReadKey;

    End.

    3:

    Program solution;

    Uses Crt;

    Var sum, num, count : Word;

    Begin

    ClrScr;

    sum : = 0;

    count : = 0;

    while sum < = 100 do

    begin

    write (': ') ;

    readln (num) ;

    sum : = sum + num;

    count : = count + 1;

    end;

    writeln ('Было введено чисел: ', count) ;

    ReadKey;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программирование. Pascal. Задача с циклом. Задача 1. Пользователь вводит 10 целых чисел. Посчитать, сколько из них положительных, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу для Pascal 1) Пользователь вводит число, количество цифр в нем неизвестно, но последняя цифра = 0. Посчитать количество четных положительных цифр в этом числе.
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
помогите решить. Всё в с++, для code blocks. 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Подсчитайте, сколько среди данных N чисел нулей, положительных чисел, отрицательных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число положительных и отрицательных чисел.
Ответы (1)