Задать вопрос
13 марта, 14:42

Даны два вектора b = (b1, b2, ..., bn), x = (x1, x2, ..., xn) и матрица А (nxn). Написать программу вычисления длины вектора Ах + b.

+1
Ответы (1)
  1. 13 марта, 17:49
    0
    Const

    N = 4;

    Var

    A:array[1 ... N, 1 ... N] of real;

    B, X, AX:array[1 ... N] of real;

    i, j:integer;

    S:real;

    Begin

    Randomize;

    Write ('B (', N,') : ') ;

    For i: = 1 to N do

    Begin

    B[i]:=random (721) - 360;

    Write (' ', B[i]:4)

    End;

    WriteLn;

    Write ('X (', N,') : ') ;

    For i: = 1 to N do

    Begin

    X[i]:=random (721) - 360;

    Write (' ', X[i]:4)

    End;

    WriteLn;

    WriteLn ('A (', N,',', N,') : ') ;

    For i: = 1 to N do

    Begin

    Write (' ') ;

    For j: = 1 to N do

    Begin

    A[i, j]:=random (721) - 360;

    Write (' ', A[i, j]:4)

    End;

    WriteLn;

    End;

    WriteLn;

    Write ('AX:') ;

    For i: = 1 to N do

    Begin

    AX[i]:=0;

    For j: = 1 to N do

    Begin

    AX[i]:=AX[i]+A[i, j]*X[j];

    End;

    Write (' ', AX[i])

    End;

    WriteLn;

    Write ('AX+B:') ;

    For i: = 1 to N do

    Begin

    X[i]:=AX[i]+B[i];

    Write (' ', X[i])

    End;

    WriteLn;

    Write ('|Ax+b| = ') ;

    S:=0;

    For i: = 1 to N do

    Begin

    S:=S+X[i]*X[i];

    End;

    WriteLn (Sqrt (S))

    End.

    Пример:

    B (4) : - 51 179 276 - 273

    X (4) : - 272 - 261 - 57 304

    A (4,4) :

    -169 - 94 245 - 346

    -351 - 176 280 1

    -193 - 330 219 - 54

    338 - 57 - 44 - 328

    AX: - 48647 125752 109727 - 174263

    AX+B: - 48698 125931 110003 - 174536

    |Ax+b| = 246563.556248688
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два вектора b = (b1, b2, ..., bn), x = (x1, x2, ..., xn) и матрица А (nxn). Написать программу вычисления длины вектора Ах + b. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Даны две матрицы А (nxn) и B (nxn), а также два вектора х = (x1, x2, ..., xn) и y = (y1, y2, ..., yn). Написать программу нахождения скалярного произведения (Ах) * (Ву).
Ответы (1)
составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица NxN.
Ответы (1)
написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица NxN.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)