Задать вопрос
30 октября, 00:45

написать программу с организацией ввода-вывода с помощью текстовых файлов.

В каждой задаче задается квадратная матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.

+4
Ответы (1)
  1. 30 октября, 01:41
    0
    var a:array[1 ... 10,1 ... 10]of integer;

    i, j, k, s:integer;

    begin

    for i:=1 to 10 do for j:=1 to 10 do a[i, j]:=random (9) + 1;

    for i:=1 to 10 do begin for j:=1 to 10 do write (a[i, j],' ') ; if j=10 then writeln; end;

    s:=1;

    for i:=2 to 10 do begin k:=a[i, 1];

    for j:=2 to 10 do begin

    if i mod 2 = 0 then if a[i, j]>k then k:=a[i, j];

    if (j=10) and (i mod 2=0) then s:=s*k;

    end;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица NxN. Программа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
составить графическую схему алгоритма и написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой задаче задается квадратная матрица NxN.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Задана матрица (двумерный массив) A размером N x М, состоящая из действительных элементов. Числа M и N вводятся с клавиатуры. Для задания исходной матрицы предусмотреть ввод с клавиатуры или ввод с помощью датчика случайных чисел.
Ответы (1)
1) все внешние устройства обмениваются данными через: а) процессор б) магистраль (системную шину) в) устройство ввода г) устройство вывода 2) к устройствам ввода данных относятся: а) принтер б) сканер в) клавиатура г) монитор 3) к устройствам вывода
Ответы (1)
Задача на C++. Двумерный массив 5*5. Для каждой строки заданной матрицы определить и напечатать сумму элементов столбцов с чётными номерами. Для каждого столбца заданной матрицы найти и напечатать максимальный элемент.
Ответы (1)