Задать вопрос
3 апреля, 03:35

Дан массив K (N), N-12. В массиве есть один элемент, значение которого равно 100. Определить его порядковый номер. Вычислить сумму значений элементов массива, стоящих перед элементом, значение которого равно 100.

+1
Ответы (2)
  1. 3 апреля, 05:07
    0
    Const

    N = 12;

    Var

    K:array[1 ... N] of integer;

    i:integer;

    S:real;

    Begin

    Write ('Введите массив K (', N,') : ') ;

    For i: = 1 to N do

    Read (K[i]) ;

    S:=0;

    i:=1;

    if K[i] = 100 then

    Write ('Перед массивом со значением 100 нет элементов.')

    else

    Begin

    While K[i]100 do

    Begin

    S:=S+K[i];

    i:=i+1;

    End;

    WriteLn ('Номер элемента со значением 100: ', i) ;

    Write ('Искомая сумма: ', S) ;

    End;

    End.
  2. 3 апреля, 07:13
    0
    Const n=12;

    var a:array[1 ... n] of integer;

    i, s:integer;

    begin

    Randomize;

    writeln ('Массив A:') ;

    for i:=1 to n do a[i]:=random (101) ;

    a[random (n) + 1]:=100;

    for i:=1 to n do write (a[i]:4) ;

    writeln;

    s:=0; i:=1;

    while a[i]100 do

    begin s:=s+a[i]; i:=i+1; end;

    writeln ('Номер элемента = 100: ', i) ;

    writeln ('s = ', s) ;

    end.

    Пример:

    Массив A:

    76 40 46 50 100 96 86 29 4 13 80 98

    Номер элемента = 100: 5

    s = 212
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив K (N), N-12. В массиве есть один элемент, значение которого равно 100. Определить его порядковый номер. Вычислить сумму значений ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Помогите написать программу! Дан целочисленный массив M из 15 элементов. Элементы массива могут принимать целые значения от - 500 до 500 и вводятся с клавиатуры. Найти и вывести: 1. Сумму квадратов отрицательных элементов.
Ответы (1)