Задать вопрос
1 июня, 12:08

Решить двумя способами. Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. Пример: Введите число? 311 Единиц: 2

+3
Ответы (1)
  1. 1 июня, 14:21
    0
    Program n1;

    var num, k: integer;

    begin

    write ('Введите число ') ;

    readln (num) ;

    k:=0;

    while num0 do

    begin

    if abs (num mod 10) = 1 then

    k:=k+1;

    num:=num div 10;

    end;

    writeln ('Единиц: ', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить двумя способами. Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Уровень C. Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи. Уровень D (на дополнительную оценку, не обязательная).
Ответы (1)
1) Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.
Ответы (1)
Напишите программу, которая получает с клавиатуры натуральное число и находит наибольшую цифру в его десятичной записи.
Ответы (1)
Напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1
Ответы (1)