Задать вопрос
26 августа, 06:45

Найти все двузначные простые числа (простым называется натуральное число, большее 1, не имеющее других делителей, кроме единицы и самого себя) для Паскаля

+1
Ответы (1)
  1. 26 августа, 08:50
    0
    Var A, i, k:byte;

    Begin

    Write ('Простые двузначные числа:') ;

    For A: = 10 to 99 do

    Begin

    k:=0;

    For i: = 2 to A div 2 do

    if A mod i = 0 then k:=k+1;

    if k = 0 then Write (' ', A)

    End

    End.

    Результат работы программы:

    Простые двузначные числа: 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти все двузначные простые числа (простым называется натуральное число, большее 1, не имеющее других делителей, кроме единицы и самого ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
Задание 1. составьте программу, определяющую, является ли число х простым. число х введите с клавиатуры. число называется простым, если у него нет других делителей, кроме 1 и его самого.
Ответы (1)
Дано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма полиндродано натуральное число N найдите сумму всех простых делителей этого числа и проверьте, не является ли полученная сумма
Ответы (1)
Найти все совершенные числа до 100000. Совершенное число - это такое число, которое равно сумме всех своих делителей, кроме себя самого. Например, число 6 является совершенным, т. к.
Ответы (1)
Условие: Дано натуральное число. Проверить, является ли оно простым. Примечание: простым называется натуральное число, которое имеет ровно два различных натуральных делителя: единицу и само это число.
Ответы (2)