Задать вопрос
26 августа, 05:10

дано натуральное число. найти максимальную цифру.

в паскале.

через while ...

+5
Ответы (1)
  1. 26 августа, 09:07
    0
    var n, k:integer;

    begin

    readln (n) ;

    k:=n mod 10;

    while n>0 do begin

    n:=n div 10;

    if k< (n mod 10) then k:=n mod 10;

    if k=9 then break;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «дано натуральное число. найти максимальную цифру. в паскале. через while ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
6.22) Дано натуральное число. Определить: а) количество цифр 3 в нем; б) сумму его цифр, больших пяти; в) произведение его цифр, больших семи; 6.26) Дано натуральное число. а) определить его максимальную цифру. б) определить его минимальную цифру.
Ответы (1)
Три фирмы A, B и C решили получить максимальную прибыль по итогам года. Экономист, хорошо знавший организацию работы в этих фирмах, высказал следующие предположения: а) фирма C получит максимальную прибыль, если максимальную прибыль получит фирма B
Ответы (1)
1. дано натуральное число n. найдите сумму его цифр 2 дано натуральное число n найдите максимальную цифру этого числа.
Ответы (1)
Переделать задачи для for 1) q:=5; d:=1; while q>0 do begin d:=d+q; dec (q) end; writeln (q,' ', d) ; 2) q:=5; d:=1; while q>0 do begin dec (q) ; d:=d+q end; writeln (q,' ', d) ; 3) q:=5; d:=1; while q>0 do dec (q) ; d:=d+q; writeln (q,' ', d) ;
Ответы (1)