Задать вопрос
18 сентября, 02:58

Сколько среди чисел 100 ... 999 таких, что в них три различные цифры идут в порядке возрастания или убывания? напечатайте их. (в паскале)

+5
Ответы (1)
  1. 18 сентября, 06:15
    0
    Var

    a, b, c, k:byte;

    Begin

    k:=0;

    For a: = 1 to 9 do

    For b: = 0 to 9 do

    For c: = 0 to 9 do

    if ((ac)) then

    Begin

    k:=k+1;

    Write (a, b, c,' ')

    End;

    WriteLn;

    WriteLn ('k = ', k) ;

    End.

    123 124 125 126 127 128 129 134 135 136 137 138 139 145 146 147 148 149 156 157 158 159 167 168 169 178 179 189 210 234 235 236 237 238 239 245 246 247 248 249 256 257 258 259 267 268 269 278 279 289 310 320 321 345 346 347 348 349 356 357 358 359 367 368 369 378 379 389 410 420 421 430 431 432 456 457 458 459 467 468 469 478 479 489 510 520 521 530 531 532 540 541 542 543 567 568 569 578 579 589 610 620 621 630 631 632 640 641 642 643 650 651 652 653 654 678 679 689 710 720 721 730 731 732 740 741 742 743 750 751 752 753 754 760 761 762 763 764 765 789 810 820 821 830 831 832 840 841 842 843 850 851 852 853 854 860 861 862 863 864 865 870 871 872 873 874 875 876 910 920 921 930 931 932 940 941 942 943 950 951 952 953 954 960 961 962 963 964 965 970 971 972 973 974 975 976 980 981 982 983 984 985 986 987

    k = 204
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сколько среди чисел 100 ... 999 таких, что в них три различные цифры идут в порядке возрастания или убывания? напечатайте их. (в паскале) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу и блок-схему для задачи: введите числа A B N если оба числа > N, то напечатайте слово "больше" если < N то слово "меньше", иначе напечатайте N "в промежутке между А и В"
Ответы (1)
1. Среди трехзначных чисел сколько таких, что сумма крайних в три раза больше средней цифры. 2. Среди трехзначных чисел сколько таких, что все цифры разные
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
Разделы документа MS Word могут иметь ... различные стили различные параметры форматирования страниц различные панели инструментов различные пункты меню
Ответы (2)
1. Напечатайте индексы всех равных элементов произвольного массива A (N; N). 2. В заданном тексте заменить последовательность символов X (I) на A (I), подсчитать количество произведенных замен. эти две задачи необходимо решить в турбо паскале
Ответы (1)