Задать вопрос
6 июня, 07:15

Составить алгоритм определения периметра треугольника, заданного координатами (х1; у1), (х2; у2) ; (х3; у3) своих вершин.

paskal

+2
Ответы (1)
  1. 6 июня, 07:21
    0
    Var x1, x2, x3, y1, y2, y3:integer;

    l1, l2, l3, P: real;

    begin

    writeln ("Введите координаты") ;

    readln (x1, y1) ;

    readln (x2, y2) ;

    readln (x3, y3) ;

    l1:=sqrt (sqr (x1-x2) + sqr (y1-y2)) ;

    l2:=sqrt (sqr (x2-x3) + sqr (y2-y3)) ;

    l3:=sqrt (sqr (x3-x1) + sqr (y3-y1)) ;

    P: = (l1+l2+l3) ;

    writeln ("Периметр равен = ", P) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить алгоритм определения периметра треугольника, заданного координатами (х1; у1), (х2; у2) ; (х3; у3) своих вершин. paskal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Найти периметр N-угольника, заданного на плоскости координатами своих вершин. (Написать функцию для нахождения длины стороны N-угольника). Паскаль, через функции пользователя.
Ответы (1)
исключи из предложенных сочетаний слов те, которые невозможны в информатике: 1) линейный алгоритм 2) прямой алгоритм 3) циклический алгоритм 4) разветвляющийся алгоритм
Ответы (2)