Задать вопрос
5 октября, 09:02

Помогите составить программу на языке паскаль

S=2+4+6 ... + n

+1
Ответы (2)
  1. 5 октября, 10:11
    0
    Var

    i, n, s:longint;

    begin

    Write ('Введите четное значение последнего члена ряда: ') ;

    Readln (n) ;

    s:=0;

    for i:=1 to n div 2 do s:=s+2*i;

    Writeln ('Сумма членов ряда равна ', s)

    end.

    Тестовое решение:

    Введите четное значение последнего члена ряда: 50

    Сумма членов ряда равна 650
  2. 5 октября, 12:42
    0
    Var s, i, n: integer;

    begin

    read (n) ;

    i:=2;

    write ('S = ') ;

    while (i<=n) do

    begin

    s:=s+i;

    i:=i+2;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите составить программу на языке паскаль S=2+4+6 ... + n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача_1: Составить программу на языке Паскаль для вычисления выражения y:=sqr (x) + x/3+sqr (sin (x)) Задача_2: Составить программу на языке Паскаль для вычисления площади треугольника по трем сторонам (подсказка: это формула Герона) Задача_3:
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
1) Написать программу на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел. 2) Написать программу на языке Паскаль, вычисляющую корни квадратного уравнения.
Ответы (1)