Задать вопрос
12 августа, 18:49

Найти периметр N-угольника, заданного на плоскости

координатами своих вершин. (Написать функцию для нахождения длины

стороны N-угольника). Паскаль, через функции пользователя.

+1
Ответы (1)
  1. 12 августа, 22:23
    0
    Program n1;

    var

    i, n: integer;

    x, y : array[1 ... 100] of integer;

    per: real;

    function dlina (x1, x2, y1, y2 : integer) : real;

    begin

    dlina : = sqrt (sqr (x2-x1) + sqr (y2-y1)) ;

    end;

    begin

    write ('введите кол-во сторон: ') ;

    readln (n) ;

    per : = 0;

    write ('введите x1 координату: ') ;

    readln (x[1]) ;

    write ('введите y1 координату: ') ;

    readln (y[1]) ;

    for i:=2 to n do

    begin

    write ('введите х', i,' координату: ') ;

    readln (x[i]) ;

    write ('введите y', i,' координату: ') ;

    readln (y[i]) ;

    per : = per + dlina (x[i-1], y[i-1], x[i], y[i]) ;

    end;

    per : = per + dlina (x[i], y[i], x[1], y[1]) ;

    writeln ('периметр искомого ', n,' угольника', per) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти периметр N-угольника, заданного на плоскости координатами своих вершин. (Написать функцию для нахождения длины стороны N-угольника). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Какая персональная информация, размещенная на онлайн-ресурсе, должна быть удалена из поисковой системы по запросу пользователя? A. Любое групповое фото, на котором есть изображение данного пользователя. B.
Ответы (2)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
Написать программу перевода из десятичной системы счисления в двоичную при помощи функций пользователя. Паскаль (Функции пользователя).
Ответы (1)