Задать вопрос
4 апреля, 10:24

Написать программу, которая обеспечивает ввод последовательности чисел. Количество чисел в последовательности неизвестно. Программа должна находить количество чисел, которое кратно 3 и заканчивается на 6.

+3
Ответы (1)
  1. 4 апреля, 13:54
    0
    Program n1;

    var a, k: integer;

    begin

    readln (a) ;

    k:=0;

    while a0 do

    begin

    if (a mod 3=0) and (a mod 10=6) then

    k:=k+1;

    readln (a) ;

    end;

    write (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая обеспечивает ввод последовательности чисел. Количество чисел в последовательности неизвестно. Программа должна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая обеспечивает ввод последовательности чисел. Количество чисел в последовательности неизвестно. Признаком конца последовательности является ввод 0.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, есть ли в последовательности нечетные числа не оканчивающихся на 1. Вход: программа получает на выход кол-во чисел, а затем сами числа.
Ответы (2)
напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 6 и оканчивающихся на 4. Программа получает на ввод натуральные числа, количество введенных чисел неизвестно.
Ответы (1)