Задать вопрос
12 августа, 17:30

Составте программу вводящую числа если число чётное разделите на 2 если не чётное умножте на 2

+1
Ответы (1)
  1. 12 августа, 18:37
    0
    Var a:integer;

    Begin

    Write ('Введите целое число: ') ; ReadLn (a) ;

    if a mod 2 = 0 then a:=a div 2

    else a:=a*2;

    Write (a)

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составте программу вводящую числа если число чётное разделите на 2 если не чётное умножте на 2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае. а) Сумма цифр трёхзначного числа х является чётным числом. б) Треугольник со сторонами a, b, с являются равносторонним.
Ответы (1)
Напишите программу, вводящую трехзначное число, первая цифра которого равна единице, вторая принадлежит промежутку от 1 до 7, а третья на две единицы больше второй.
Ответы (2)
Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае: б) Треугольник со сторонами a, b, с являются равносторонним.
Ответы (1)
Помогите написать в паскале! Ввести три целых числа x, y, z. Если хотя бы одно из них четное, то первому четному числу присвоить значение произведения этих чисел.
Ответы (1)
Задача 2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется четное число.
Ответы (1)