Задать вопрос
27 апреля, 08:54

Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае.

а) Сумма цифр трёхзначного числа х является чётным числом.

б) Треугольник со сторонами a, b, с являются равносторонним.

+1
Ответы (1)
  1. 27 апреля, 11:34
    0
    uses crt;

    var a, b, c, n, n1:integer;

    begin

    readln (n) ;

    n1: = (n div 100) + ((n div 10) mod 10) + (n mod 10) ;

    if (n1 mod 2 = 0) then write ('true') ;

    if (n1 mod 2 = 1) then write ('false') ;

    readln (a, b, c) ;

    if (a=b) and (a=c) and (b=c) then write ('true')

    else write ('false')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае. а) Сумма цифр трёхзначного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
Составьте программу в Паскаль, вводящую true, если высказывание является истинным, и false в противном случае: б) Треугольник со сторонами a, b, с являются равносторонним.
Ответы (1)
составьте программу печатающую значение true если указанное высказывание является истинным и false в противном случае сумма цифр данного трехзначного числа N является четным числом
Ответы (1)
1. Вычислите логические выражения: not true and not false not true or not false not (true or false) not (true and false) 2. Напишите условие нахождения точки a в первом квадранте системы координат, считая ее координаты заданными X переменными x, y.
Ответы (1)
Составить программу печатающую значение true если указанное высказывание является истинным и false в противном случае треугольник со сторонами а в с является равнобедренным
Ответы (1)