Задать вопрос
24 февраля, 00:45

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30000. Программа должна вывести два числа: длину последовательности и сумму чётных чисел.

+4
Ответы (1)
  1. 24 февраля, 02:51
    0
    Program g; var sum, a, b: integer; begin b : = 0; sum : = 0; repeat read (a) ; if (a mod 2 = 0) then sum + = a; if (a0) then b + = 1; until (a = 0) ; write ('Сумма четных чисел - ', sum,' Общее кол-во чисел - ', b) end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел. Программа получает на вход ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая находит сумму четных чисел, больших 5, в последовательности целых чисел. Программа получает на выход целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (признак окончания ввода,
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
1) Напишите программу, которая в последовательности натуральных чисел определяет сумму четырехзначных чисел, кратных 6.
Ответы (1)
Прошу Помогите я вам буду очень благодарен! Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256.
Ответы (1)