Задать вопрос
3 августа, 23:15

Проверочная работа

Составить программы для вычисления:

a) Среднего арифметического кубов двух целых чисел m и n.

Ответ дать с точность до трёх знаков после запятой.

б) Дано четырёхзначное число. Найти остаток от деления чисел образованных первыми двумя цифрами и последними двумя цифрами этого числа

+1
Ответы (1)
  1. 4 августа, 00:32
    0
    {Среднего арифметического кубов двух целых чисел m и n.

    Ответ дать с точность до трёх знаков после запятой. }

    var

    m, n: integer;

    begin

    read (m, n) ;

    writeln ((m * m * m + n * n * n) / 2:3) ;

    end.

    {Дано четырёхзначное число. Найти остаток от деления

    чисел образованных первыми двумя цифрами и последними

    двумя цифрами этого числа}

    var

    i, n, n1, n2: integer;

    begin

    read (n) ;

    n1 : = n div 100;

    n2 : = n mod 100;

    writeln (n1 mod n2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Проверочная работа Составить программы для вычисления: a) Среднего арифметического кубов двух целых чисел m и n. Ответ дать с точность до ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
1 Написать процедуру вычисления среднего арифметического двух чисел. Числа и результат передаются в качестве параметров , в каком из двух введенных с клавиатуры целых чисел произведение цифр больше.
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)