Задать вопрос
31 декабря, 21:35

В строке S1 заменить нечётные символы на строку S2. Программа в Паскале

+3
Ответы (1)
  1. 1 января, 01:17
    0
    Var

    S1, S2, S3:string;

    i:integer;

    Begin

    Write ('S1: ') ; ReadLn (S1) ;

    Write ('S2: ') ; ReadLn (S2) ;

    For i: = 1 to Length (S1) do

    if i mod 2 = 0 then S3:=S3+S2

    else S3:=S3+S1[i];

    S1:=S3;

    Write ('S1: ', S1) ;

    End.

    Пример:

    S1: 123456789

    S2: ||

    S1: 1||3||5||7||9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В строке S1 заменить нечётные символы на строку S2. Программа в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вася учится в школе. Недавно учитель записал на доске строку из строчных латинских букв и цифр, а Вася переписал эту строку в тетрадку. Придя домой, Вася столкнулся с проблемой в прочтении строки.
Ответы (1)
Напишите программу, которая считает знаки пунктуации в символьной строке. К знакам пунктуации относятся символы из набора ".,; :?!". Формат входных данных Программа получает на вход символьную строку (длина строки не больше 100 символов).
Ответы (1)
Напишите программу в Паскале, которая выводит на экран только нечётные символы (символы под номерами 1, 3, 5, ...) из текста пользователя.
Ответы (1)
Помогите сделать программу в Паскале В котором 1) Программа выдает сообщение "Вы маль или дево" 2) Пользователь в переменную ST1 задает значение маль или дево 3) Программа выдает сооб "Ты пошла бы играть в куклы" 4) Вводить ответ через переменную
Ответы (1)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)