Задать вопрос
30 июля, 22:30

Напишите программу, которая считает знаки пунктуации в символьной строке. К знакам пунктуации относятся символы из набора ".,; :?!". Формат входных данных Программа получает на вход символьную строку (длина строки не больше 100 символов). Формат выходных данных Программа должна вывести общее количество знаков пунктуации во входной строке. Примеры входные данные выходные данные Hi, guys! 2

+4
Ответы (1)
  1. 30 июля, 23:54
    0
    Var s, p:string; k, i:integer;

    begin

    readln (s) ;

    p:='.,; :?!';

    k:=0;

    for i:=1 to length (s) do

    if pos (s[i], p) >0 then k:=k+1;

    writeln ('k = ', k) ;

    end.

    Пример:

    Hi, guys!

    k = 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая считает знаки пунктуации в символьной строке. К знакам пунктуации относятся символы из набора ".,; :?!". Формат ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. Входные данные На вход программы подаётся символьная строка.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово - это последовательность непробельных символов, ограниченная пробелами или концами строки.
Ответы (1)