Задать вопрос
1 декабря, 19:13

Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке.

Входные данные

На вход программы подаётся символьная строка.

Выходные данные

Программа должна вывести количество различных символов в этой строке.

Примеры

входные данные

aB122AB

выходные данные

5

Pascal ABC 1.8

+5
Ответы (1)
  1. 1 декабря, 21:52
    0
    Var used: Set of Char;

    s: string;

    i, cnt: integer;

    c: char;

    begin

    used : = [];

    readln (s) ;

    for i : = 1 to length (s) do

    include (used, s[i]) ;

    cnt : = 0;

    for c : = #0 to #255 do

    if (c in used) then

    cnt : = cnt + 1;

    writeln (cnt) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. Входные данные На вход программы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая проверяет правильность имени переменной в языке Паскаль. Имя может содержать только латинские буквы (заглавные и строчные), цифры и знак подчёркивания, но не может начинаться с цифры.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)