Задать вопрос
26 апреля, 22:59

Напишите программу, которая проверяет правильность имени переменной в языке Паскаль. Имя может содержать только латинские буквы (заглавные и строчные), цифры и знак подчёркивания, но не может начинаться с цифры.

Входные данные

На вход программы подаётся символьная строка, содержащая имя переменной.

Выходные данные

Программа должна вывести ответ 'YES', если строка представляет собой правильное имя переменной в языке Паскаль, и 'NO', если имя ошибочно.

Примеры

входные данные

Abc123

выходные данные

YES

входные данные

Abc[a!

выходные данные

NO

Pascal ABC 1.8 с использованием множеств

+3
Ответы (1)
  1. 27 апреля, 00:07
    0
    Var s: string;

    i: integer;

    good: boolean;

    begin

    readln (s) ;

    good : = True;

    if (s[1] in ['0' ... '9']) then

    good : = False

    else

    begin

    for i : = 1 to length (s) do

    if not ((s[i] in ['a' ... 'z']) or (s[i] in ['A' ... 'Z']) or (s[i] in ['0' ... '9']) or (s[i] = '_')) then

    good : = False;

    end;

    if (good) then

    writeln ('YES')

    else

    writeln ('NO') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая проверяет правильность имени переменной в языке Паскаль. Имя может содержать только латинские буквы (заглавные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. Входные данные На вход программы подаётся символьная строка.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
На паскале Даны две строки. Определите, является ли первая строка подстрокой второй строки. Входные данные На вход подается 2 строки длины не более 10000, состоящие только из маленьких букв латинского алфавита.
Ответы (2)
1. Что из ниже перечисленного не входит в алфавит языка Паскаль? а) латинские строчные и прописные буквы б) служебные слова в) русские строчные и прописные буквы г) знак подчёркивания
Ответы (1)