Задать вопрос
14 июня, 04:42

Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово - это последовательность непробельных символов, ограниченная пробелами или концами строки.

Входные данные

Входная строка содержит произвольную последовательность символов.

Выходные данные

Программа должна вывести последнее слово этой строки.

Примеры

входные данные

Abra babra cadabra

выходные данные

cadabra

+5
Ответы (1)
  1. 14 июня, 08:33
    0
    Program z1; Var i, b, j, n:integer; s, space, h:string; a: array [1 ... 1000] of string; Begin write ('Введите текст - ') ; readln (s) ; b:=length (s) ; space:=' '; i:=1; n:=0; j:=1; while i<=b do begin h:=''; while s[i]space do begin h:=h+s[i]; i:=i+1; end; a[j]:=h; j:=j+1; i:=i+1; n:=n+1; end; write (a[n],' ') ; End. Только в конце предложения ставь тоже пробел!
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая выводит последнее слово переданной её символьной строки. Слово - это последовательность непробельных символов, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. Входные данные Входная строка содержит три целых числа, разделённых пробелами.
Ответы (1)
Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. Входные данные На вход программы подаётся символьная строка.
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)