Задать вопрос
15 сентября, 18:39

Составьте программу вычисления суммы S=10+12+14 ... + 50

+1
Ответы (1)
  1. 15 сентября, 20:51
    0
    Это прогрессия с шагом d=12-10=2

    1 член=10

    50 - последний член

    an=a1+d (n-1)

    50=10+2n-2

    2n=42;

    n=21 - в последовательности 21 член

    для программы используем формулу суммы арифм. прогрессии: Sn = (a1+an) * n/2;

    составляем программу:

    Program n1;

    const a1=10;

    an=50;

    n=21;

    var S: real;

    begin

    S: = (a1+an) * n/2;

    writeln (S) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления суммы S=10+12+14 ... + 50 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)
1) Составьте программу вычисления сумму чисел от 1 до 100. 2) Составьте программу вычисления произведения чётных чисел от 1 до 10. 3) Составьте программу вычисления количества двухзначных нечётных чисел.
Ответы (1)
Используя язык программирования Паскаль выполнить задание: 1. Составить программу для вычисления y=38x+231. 2. Составить программу для вычисления M=7x+6y+276. 3. Составить программу для вычисления N=4a2+2xa+8y.
Ответы (1)
1) составьте программу вычисления в массиве А, содержащего N элементов, произведения положительных чисел. Pascal 2) составьте программу вычисления суммы элементов от первого отрицательного и до конца. Pascal
Ответы (1)
1) Составьте программу вычисления произведения S=1*2+3*4+5*6 + ... + 101*102 (в паскале) 2) составьте программу вычисления суммы S=0.5+1.5+2.5 + ... + 98.5+99.5
Ответы (1)