Задать вопрос
19 августа, 19:18

Напишите программу в pascal abc

Для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел.

+5
Ответы (1)
  1. 19 августа, 19:44
    0
    Var

    n, S, S3:integer;

    Begin

    Write ('n = ') ;

    ReadLn (n) ;

    For n: = 1 to n do

    Begin

    S:=S+n;

    if n mod 3 = 0 then S3:=S3+n;

    End;

    WriteLn ('Сумма чисел [1 ... ', n,'], кратных трём: ', S3) ;

    WriteLn ('Сумма всех чисел [1 ... ', n,']: ', S) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в pascal abc Для первых n натуральных чисел вычислить сумму чисел, кратных 3 и сумму всех чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)