Задать вопрос
23 марта, 13:42

Паскаль. даны 10 двухзначных чисел. выведите сумму тех, которые не делятся на 3

+3
Ответы (1)
  1. 23 марта, 15:04
    0
    Const n=10;

    var a:array[1 ... n] of integer;

    i, s:integer;

    begin

    Randomize;

    for i:=1 to n do

    begin

    a[i]:=random (90) + 10;

    write (a[i]:4) ;

    end;

    writeln;

    s:=0;

    for i:=1 to n do

    if a[i] mod 3 0 then s:=s+a[i];

    writeln ('Сумма тех, которые не делятся на 3 = ', s) ;

    end.

    Пример:

    65 37 24 68 17 56 17 77 34 99

    Сумма тех, которые не делятся на 3 = 371
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль. даны 10 двухзначных чисел. выведите сумму тех, которые не делятся на 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Паскаль: с Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.
Ответы (1)
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты. Если произведение этих чисел положительно, то выведите утроенное значение каждого числа.
Ответы (1)
Решить в Паскаль АБЦ! Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число. "Входные данные" Вводятся два числа. "Выходные данные" Выведите ответ на задачу.
Ответы (1)